Phone system outage

Major incident Telephone System
2022-03-23 10:28 UTC · 2 hours, 7 minutes, 25 seconds

Updates

Resolved

The issues faced with our phone systems have been resolved and usual service has resumed.

March 23, 2022 · 12:35 UTC
Investigating

Our phone system provider continues to investigate this issue.

March 23, 2022 · 12:02 UTC
Issue

Our phone system is currently out of service. We are in close contact with our service provider who are currently investigating. We’ll update you soon.

March 23, 2022 · 10:31 UTC

← Back