Disclosure Scotland basic checks

Minor incident HR Platform
2023-08-18 14:24 UTC · 2 weeks, 5 days, 19 hours, 59 minutes

Updates

Resolved

This issue has now been resolved.
Processing of queued applications will resume shortly, thank you for your patience.

September 7, 2023 · 10:11 UTC
Investigating

We are investigating technical issues relating to the submission of Disclosure Scotland basic checks.

Applications can still be submitted; however, they will show as ‘awaiting countersignatory’ instead of ‘in processing’.

We are working closely with Disclosure Scotland to resolve this as quickly as possible.

Thank you for your patience.

August 18, 2023 · 14:24 UTC

← Back